Apache Directory Studio

User's Guide
# Table of Contents

I. Getting started .................................................................................................................. 1  
1. Download and install ........................................................................................................ 1  
II. Tasks .................................................................................................................................... 2  
1. Running Apache Directory Studio .................................................................................... 2  
2. Updating Apache Directory Studio .................................................................................... 2  
2.1. Enabling, disabling and uninstalling features ............................................................... 2  
3. Reporting a bug ..................................................................................................................... 3  
III. Reference .......................................................................................................................... 4  
1. Preferences ......................................................................................................................... 4  
   1.1. Apache Directory Studio ............................................................................................... 4  
   1.2. General ......................................................................................................................... 4  
   1.3. Help .................................................................................................................................. 7  
   1.4. Install/Update ................................................................................................................... 9  
   1.5. Installed JREs ............................................................................................................... 11  
IV. What's new ......................................................................................................................... 13  
V. Release notes ....................................................................................................................... 15
Chapter I. Getting started

1. Download and install


System requirements

• Mac OS X 10.4 or later, Windows, Linux

• Java Runtime Environment [http://www.java.com/] 5 or later

Installing on Mac OS X

Follow this installation process:

• Step 1: Double-click the downloaded package to mount the Apache Directory Studio DMG.

• Step 2: Drag and drop the Apache Directory Studio application to your Applications folder.

Installing on Linux

Follow this installation process:

• Step 1: Uncompress the Tar Gzip archive ('tar xzf ApacheDirectoryStudio-1.0.0-linux-i386.tar.gz' for the i386 Linux version).

• Step 2: Move the ApacheDirectoryStudio folder to the location of your choice.

Installing on Windows

Follow this installation process:

• Unzip the Zip archive.

• Run the installer and follow install instructions.
Chapter II. Tasks

1. Running Apache Directory Studio

Mac OS X

If you followed the instructions on the "Download and install" page, simply double-click the Apache Directory Studio application located in your Applications folder.

Linux

After installing the Apache Directory Studio in a directory, you can start Apache Directory Studio by running the ApacheDirectoryStudio executable included with the release.

Windows

If you followed the instructions on the "Download and install" page, simply click on the Apache Directory Studio executable in the Apache Directory Studio folder located in the All programs item of the Start menu.

2. Updating Apache Directory Studio

To check to see whether there are updates for features of Apache Directory Studio (requires Internet access):

1. Click Help > Software Updates > Search for updates... . This will contact Apache Directory Studio Web site to discover what versions of those features are available. The potential upgrades are presented in on the next page.

2. Select the feature versions that you wish to upgrade, and click Next .

3. Carefully review the license agreements for the upgraded features. If the terms of all these licenses are acceptable, check "I accept the terms in the license agreements." Do not proceed to download the features if the license terms are not acceptable.

4. Feature versions can be digitally signed by the company that provides them. This allows you to verify more easily that the features and plug-ins that are about to be downloaded and installed are coming from a trusted supplier.

Click Install to allow the downloading and installing to proceed.

5. Once all the features and plug-ins have been downloaded successfully and their files installed into the product on the local computer, a new configuration that incorporates these features and plug-ins will be formulated. Click Yes when asked to exit and restart the Workbench for the changes to take effect.

2.1. Enabling, disabling and uninstalling features

You can browse and manage your configuration from the Product Configuration dialog . Open the Product Configuration dialog by clicking Help > Software Updates > Manage Configuration .

1. Disabling a feature : select the feature and click Disable in the right pane of the dialog. This option is available only when the feature is currently enabled, and the feature is either an optional feature or a root feature (not included by other features).
2. **Enabling a feature** : First, ensure **Show Disabled Features** is turned on in the tool bar. Then, select a disabled optional or root feature and click **Enable** in the right pane of the dialog.

3. **Uninstalling a feature** : features that you have installed using the update manager can be uninstalled, provided they are already disabled, or that they are optional or root features. If the feature is disabled, make sure **Show Disabled Features** is turned on in the tool bar. Select the feature and click **Uninstall** in the right page of the dialog.

### 3. Reporting a bug

Use the **Help > Report a bug...** menu item to report any bug you find on Apache Directory Studio.

You will be redirected on your default Web browser to our issue tracking software called Jira.

You can also reach it using this address: `https://issues.apache.org/jira/browse/DIRSTUDIO` [https://issues.apache.org/jira/browse/DIRSTUDIO]

To report a bug:

1. Click the **Create a new issue** link in the menu.

2. Make sure the selected project is 'Directory Studio' and the issue type is 'Bug'. Click **Next**.

3. Fill in the issue form giving the more details you can on the bug you have found.

4. Click the **Create** button to create the new issue.
Chapter III. Reference

1. Preferences

The Preferences dialog is the dialog used to set user preferences. The Preferences dialog pages can be searched using the filter function. To filter by matching the page title, simply type the name of the page you are seeking and the available pages will be presented below. The filter also searches on keywords such as appearance and java. The history controls allow you to navigate through previously viewed pages. To step back or forward several pages at a time, click the drop down arrow and a list of the most recently viewed preference pages will appear.

The Preferences dialog can be found from the main workbench Window menu under Window > Preferences. Preference pages contributed by plug-ins will be found in this dialog.

1.1. Apache Directory Studio

The Apache Directory Studio preferences page is the root for all the preferences settings for the Apache Directory Studio specific plugins.

Here is what the Apache Directory Studio preferences page looks like:

1.2. General

On the Help preferences page, you can indicate how to display help information.

The following preferences can be changed on the General preference page.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always run in background</td>
<td>Turn this option on to perform long running operations in the background without blocking you from doing other work.</td>
<td>Off</td>
</tr>
<tr>
<td>Keep next/previous part dialog open</td>
<td>If this option is turned on then the editor and view cycle dialogs will remain open when their activation key is let go. Normally the dialog closes as soon as the key combination is release.</td>
<td>Off</td>
</tr>
<tr>
<td>Show Heap Status</td>
<td>Turn this option on to display an indicator showing information about current Java heap usage.</td>
<td>Off</td>
</tr>
</tbody>
</table>

Open mode... You can select one of the following methods for opening resources:

- **Double click** - Single clicking on a resource will select it and double clicking on it will open it in an editor.

- **Single click (Select on hover)** - Hovering the mouse cursor over the resource will select it and clicking on it once will open it in an editor.

- **Single click (Open when using arrow keys)** - Selecting a resource with the arrow keys will open it in an editor.

**Note:** Depending on which view has focus, selecting and opening a resource may have different behavior.

Here is what the General preferences page looks like:
1.2.1. Network Connections

The following preferences can be changed on the Network Connections page:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Direct connection to the Internet</td>
<td>Enable this option to have all connections to remote systems happen directly without involving a proxy server.</td>
<td>Enabled</td>
</tr>
<tr>
<td>Manual configuration</td>
<td>Use this option if connections to remote systems should happen through a proxy server.</td>
<td>Disabled</td>
</tr>
<tr>
<td>HTTP Proxy</td>
<td>Use this option to specify the server and port that is to be used when making HTTP connections. If the port field is empty, the default port of 80 is used. If the &quot;Use this proxy server for SSL&quot; is checked, the HTTP proxy server is used for SSL connections as well.</td>
<td></td>
</tr>
<tr>
<td>SSL Proxy</td>
<td>Use this option to specify the server and port that is to be used when making SSL connections. If the port field is empty, the default port of 443 is used.</td>
<td></td>
</tr>
<tr>
<td>SOCKS Proxy</td>
<td>Use this option to specify the server and port that is to be used when making SOCKS connections. If the port field is empty, the default port of 1080 is used. [1]</td>
<td></td>
</tr>
<tr>
<td>Non-proxied Hosts (No Proxy for)</td>
<td>Use this table to specify, either by name or pattern, which hosts should not use any proxy but instead should always be connected to directly.</td>
<td></td>
</tr>
</tbody>
</table>
Here is what the Network Connections preferences page looks like:

1. The SOCKS proxy support in Java 1.4 had certain limitations. Due to these limitations, the setting of the SOCKS system properties is not performed when a 1.4 VM is used. The SOCKS proxy may still be used by some tooling when running on a 1.4 VM (e.g. CVS). However, users should use a 1.5 (or 5.0) VM if they require full SOCKS proxy support.

### 1.3. Help

On the **Help** preferences page, you can indicate how to display help information.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use external browsers</td>
<td>If embedded web browser is supported on your system, help window uses an embedded help browser to display help contents, whenever possible, and this option is available. Select it, to force help to use external browsers. Use &quot;Web Browser&quot; preference page to select browser to use.</td>
<td>Off</td>
</tr>
<tr>
<td>Open window context help</td>
<td>This option allows you to determine whether the window context help will be opened in a dynamic help view or in an infopop.</td>
<td>in dialog tray</td>
</tr>
</tbody>
</table>
Reference

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help view document open mode</td>
<td>This option allows you to determine whether the documents selected in the help view will be opened in place or in the editor area.</td>
<td>Open in place</td>
</tr>
<tr>
<td>Search</td>
<td>Determines whether potential hits should be shown while searching. Showing potential hits will increase search performance, at the cost of potential loss of accuracy.</td>
<td>Show all potential hits (faster)</td>
</tr>
</tbody>
</table>

Here is what the Help preferences page looks like:

![Help preferences page]

1.3.1. Help Content

Help topics from remote servers can be included seamlessly into the local help system. Use the Help > Content preference page to configure one or more remote server to include content from.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include help content from a remote infocenter</td>
<td>If checked, this option enables the use of remote help content. The rest of the fields on the page are only enabled if this option is checked.</td>
</tr>
<tr>
<td>Add/Edit/Delete</td>
<td>Add, edit or delete a remote data source</td>
</tr>
<tr>
<td>View Properties</td>
<td>View the properties for this remote data source</td>
</tr>
<tr>
<td>Test Connection</td>
<td>Tests to see if it is possible to connect to this host/port combination</td>
</tr>
<tr>
<td>Disable/Enable</td>
<td></td>
</tr>
</tbody>
</table>
### Reference

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Allows a data source to be disabled so the help system will not try to read topics from that source.</td>
</tr>
</tbody>
</table>

Here is what the Help Content preferences page looks like:

![Help Content Preferences Page](image)

### 1.4. Install/Update

The following preferences can be changed on the Install/Update page:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum number of 'History' configurations</td>
<td>Maximum number of configurations you want 100 maintained in the configuration history. These configurations are maintained to allow you to revert to a previous configuration of installed feature versions.</td>
</tr>
<tr>
<td>Check digital signatures of downloaded archives</td>
<td>This option will check for digital signatures of On downloaded archives.</td>
</tr>
<tr>
<td>Valid updates</td>
<td>Assuming that feature versions use the form equivalent 'major.minor.service', you can select what update level you want to choose from:</td>
</tr>
<tr>
<td></td>
<td>- equivalent : Only service updates will be displayed.</td>
</tr>
<tr>
<td></td>
<td>- compatible : Service updates and minor updates will be displayed.</td>
</tr>
</tbody>
</table>

![Install/Update Preferences Page](image)
Here is what the Install/Update preferences page looks like:

1.4.1. Automatic Updates

The following preferences can be changed on the Automatic Updates page:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically find new updates and notify me</td>
<td>When selected, Update manager will automatically search for update, as defined by the update schedule</td>
<td>Off</td>
</tr>
<tr>
<td>Update Schedule</td>
<td>Look for updates on each startup, or once a day or on startup some day a week, at a predefined time.</td>
<td></td>
</tr>
<tr>
<td>Download Options</td>
<td>This option allows you to choose between having Eclipse search for updates and notifying you of them once they are available or having Eclipse automatically download new updates and asking you to install them.</td>
<td></td>
</tr>
</tbody>
</table>

Here is what the Automatic Updates preferences page looks like:
1.5. Installed JREs

The following preferences can be changed on the Installed JREs page:

This page allows a new default JRE to be selected as well as adding new JRE installations.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installed JREs</td>
<td>The current listing of installed JREs, allowing you to select the one to act as the workspace default</td>
<td></td>
</tr>
<tr>
<td>Add...</td>
<td>Adds a new JRE definition to the workbench. In the resulting dialog, specify the following:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• JRE type: (select a VM type from the drop-down list)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• JRE name: Type a name for this JRE definition</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• JRE home directory: Type or browse to select the root directory for this JRE installation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Default VM arguments: Type the VM arguments to be used on the command line each time this JRE is used to run or debug a program</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Use the JRE system libraries list to manage the libraries associated with the JRE. These are the</td>
<td></td>
</tr>
</tbody>
</table>
Reference

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>libraries that appear on the build path and default runtime boot path.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• You can add, remove, and re-order the libraries</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• You can specify a source attachment and javadoc location for each library. Multi-select to modify more than one library at once.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Use the Restore Default button to revert to the JRE’s default libraries</td>
<td></td>
</tr>
<tr>
<td>Edit...</td>
<td>Allows you to edit the selected JRE.</td>
<td></td>
</tr>
<tr>
<td>Copy...</td>
<td>Creates a copy of the selected JRE with the same attributes and a new name.</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected JRE from the workbench.</td>
<td></td>
</tr>
<tr>
<td>Search...</td>
<td>Automatically searches for JREs installed in the local file system and creates corresponding JRE definitions in the workspace.</td>
<td></td>
</tr>
</tbody>
</table>

Here is what the Installed JREs preferences page looks like:
Chapter IV. What's new

What's new in 1.5.0

Eclipse 3.5 Galileo dependencies

Apache Directory Studio now uses the latest and greatest Eclipse 3.5 Galileo dependencies.

What's new in 1.4.0

Internationalization

Apache Directory Studio is now fully internationalized. Out of the box English, French and German translations are provided.

What's new in 1.2.0

New Save and Print actions

Two new actions have been added to the main toolbar of Apache Directory Studio: Save and Print actions.

Network Connections preference page

The Network Connections preference page from Eclipse has been added to Apache Directory Studio. This page allows the user to set up its network connection settings, such as direct connection or proxy configuration (HTTP, SSL, SOCKS Proxy).
Chapter V. Release notes

Apache Directory Studio 1.5.2 - (2009, December 11th)

Nothing new.

Apache Directory Studio 1.5.1 - (2009, November 30th)

Nothing new.

Apache Directory Studio 1.5.0 - (2009, November 2nd)

Bug

• [DIRSTUDIO-514] - Unable to restore last opened ldif-editors on restart
• [DIRSTUDIO-499] - SOCKS proxy settings not used on startup
• [DIRSTUDIO-370] - Welcome screen subpages mouse-over images displays red crosses

Task

• [DIRSTUDIO-525] - Remove support for the Linux PPC distribution
• [DIRSTUDIO-523] - Update Eclipse dependencies to version 3.5 Galileo

Apache Directory Studio 1.4.0 - (2009, April 7th)

Improvement

• [DIRSTUDIO-478] - The 'Exit' menu item from the 'File' menu should be removed when running on Mac OS X
• [DIRSTUDIO-477] - Update Eclipse dependencies to version 3.4.2

New Feature

• [DIRSTUDIO-397] - Request for multi-language GUI

Task

• [DIRSTUDIO-480] - Update copyright year in the splash screen to 2009
• [DIRSTUDIO-458] - [I18n] Bundle Eclipse language packs
Apache Directory Studio 1.3.0 - (2008, November 24th)

**Improvement**
- [DIRSTUDIO-255] - Run in background should be configurable so one could set it to true by default

**Task**
- [DIRSTUDIO-376] - Move to the latest Eclipse 3.4 dependencies
- [DIRSTUDIO-375] - Move each plugin IDs in a plugin.properties file

Apache Directory Studio 1.2.0 - (2008, August 18th)

**Bug**
- [DIRSTUDIO-347] - Keybinding conflict for CTRL+Q
- [DIRSTUDIO-330] - CoreException raised in editor when opening a *.txt file
- [DIRSTUDIO-325] - Keybinding conflicts occurred. They may interfere with normal accelerator operation.
- [DIRSTUDIO-342] - Relax the parser for the *.schema files
- [DIRSTUDIO-266] - OpenLDAP schema files parser fails when DESC contains an empty string "

**Improvement**
- [DIRSTUDIO-337] - Add Save and Print actions in the toolbar of the RCP application
- [DIRSTUDIO-295] - Add a console for errors

**New Feature**
- [DIRSTUDIO-321] - Need to be able to set SOCKS proxy in the RCP version

**Task**
- [DIRSTUDIO-339] - Add the 'org.eclipse.ui.carbon' Eclipse plugin to the Mac OS X distribution
- [DIRSTUDIO-338] - Update Eclipse dependencies to the latest Eclipse version (3.3.2)

Apache Directory Studio 1.1.0 - (2008, March 31st)

**Task**
- [DIRSTUDIO-280] - Remove remaining unwanted contributions from Eclipse
Apache Directory Studio 1.0.0 (2007, september 3rd) : initial release

Includes :

• Apache Directory Studio Apache DS Configuration 1.0.0
• Apache Directory Studio LDAP Browser 1.0.0
• Apache Directory Studio LDIF Editor 1.0.0
• Apache Directory Studio RCP 1.0.0
• Apache Directory Studio Schema Editor 1.0.0